• Article for your preferred language does not exist. Below is international version of the article.

Article ID: 119597, created on Jan 11, 2014, last review on Jan 21, 2016

  • Applies to:
  • Plesk Automation 11.1
  • Plesk Automation 11.5

Symptoms

Unable to install Plesk Automation 11.5. Installation fails with following error:

2016-01-19 11:44:26,420 [LOGTEE]: Exception: Failed to solve dependencies:
2016-01-19 11:44:26,420 [LOGTEE]: php-imap-5.3.3-27.el6_5.x86_64 requires php-common(x86-64) = 5.3.3-27.el6_5
2016-01-19 11:44:26,420 [LOGTEE]: php-mbstring-5.3.3-27.el6_5.x86_64 requires php-common(x86-64) = 5.3.3-27.el6_5
2016-01-19 11:44:27,224 [LOGTEE]:
2016-01-19 11:44:27,224 [LOGTEE]: ERROR: The Yum utility failed to install the required packages.

Cause

The package php-common was found in OS repositories, but the packages php-imap and php-mbstring were not. Since that installer tries to install these packages from Plesk Automation repository, but these packages have version different from php-common which comes from system repository.

Resolution

On CentOS 6:

The packages php-imap and php-mbstring are supplied by updates repository so it has to be enabled:

# yum-config-manager --enable updates

On RedHat 6:

The packages php-imap and php-mbstring are supplied by Optional channel. In order to enable it issue the following command:

# yum-config-manager --enable rhel-6-server-optional-rpms

For details please refer to the following RedHat KB:

https://access.redhat.com/solutions/221963

Additional information

Cannot install PPA: "unresolved dependencies for psa-php5-configurator"

Search Words

The Yum utility failed to install the required packages

cannot install PPA

installation failed

requires php-common

failed to solve dependencies

33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065 c1ecc6010feff26cb42d1d14a7881dd6

Email subscription for changes to this article
Save as PDF