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Article ID: 114461, created on Jul 27, 2012, last review on May 11, 2014

  • Applies to:
  • Business Automation

Symptoms

Domain availability check works incorrectly in PBA Online Store - free domains are shown as taken when customer is trying to register new domain name. PBA is configured to check domain availability through WHOIS plug-in.

Cause

There may be many reasons of the problem including but not limited by the following ones:
  • WHOIS plug-in is configured incorrectly.
  • WHOIS server configured in PBA plug-in is unreachable or overloaded.
  • Limit on WHOIS requests is reached.
  • PBA domain registration container hung.

Resolution


The general way to find the reason of problem is to check the log of WHOIS container ~bm/log/WHOIS.log on PBA Management Node. PBA will put request to WHOIS server and its response to the log file.

Also, it is advised to check log of the PBA domain registration container which is configured to register/transfer domains in the problem TLD (Top-Level Domain zone).

Perform the basic checks listed below to find the reason of problem.

1. Check the WHOIS plug-in configuration in PBA Provider Control Panel at External Systems Director > Domain Manager > Registrars:

  • Whois server - put hostname or IP address of the WHOIS server which will be used to check domain availability.
  • RegExp type - select one of two available options:
    • domain available
    • domain not available
  • RegExp - put the correct regular expression which PBA will search in the response from WHOIS server to make decision whether domain is available for registration or not.
  • Request Pattern - pattern of a request to be sent to WHOIS server, in most cases just leave the default value %domain%, this means that PBA will just send name of the domain to be checked to the WHOIS server.

E.g. for .COM domains the WHOIS plug-in configuration may be as follows:
  • Whois server    whois.internic.net
  • RegExp type        domain available
  • RegExp            No match for
  • Request Pattern    %domain%

In the example provided above PBA will send WHOIS requests to the whois.internic.net server, domain name will be sent in the request. If the string No match for is found in the response from WHOIS server PBA will consider domain as available for registration since the domain was not foind in the WHOIS database.

The main idea of WHOIS-based domain availability checking is to find string in WHOIS server response which may unambigously indicate whether a domain is free or not. This may be a problem to find such string because different WHOIS servers have different response format.

So, if incorrect regular expression type or pattern are entered in WHOIS plug-in configuration PBA will not be able to check domain availability correctly.

2. Check if PBA can connect to the WHOIS server configured in PBA plug-in:

  • Log into PBA Management Node
  • Check connectivity to WHOIS server (port 43) using the telnet utility: telnet whois.internic.net 43
Replace whois.internic.net in the command above with actual name of WHOIS server configured in PBA plug-in.

If PBA cannot connect to WHOIS server check the following aspects:
  • PBA must be able resolve WHOIS server hostname to IP address
  • There should be no firewall which may prevent outgoing connections from PBA Management Node to port 43

3. Check if the limit on number of requests to WHOIS server is not exceeded.

Some WHOIS servers impose limit on number of requests within a period of time (hour, day or month), so PBA may ran out of this limit and all requests to WHOIS server will fail until limit is reset.

In this case you will see corresponding error message in the ~bm/log/WHOIS.log file on PBA Management Node like in the example below: [12-07-27 01:29:28.089 Worker1.4   TH28520 NTE] Trying to send request for domain:customer.se
[12-07-27 01:29:28.269 Worker1.4   TH28520 NTE]
Response: Request denied!
The monthly overall-limit of requested domains (5000)
has been reached for IP-Address (192.168.1.101).
Please contact our support and/or sales-department for further information.

Note: depending on the used WHOIS server response about exceeded limit may be different.

4. Finally, if all actions above did not solve the problem, try to restart PBA container which is used to handle domain operations in the problem TLD using the command below:

PBA for Linux: # service pba restart CONTAINER
PBA for Windows: ssm restart CONTAINER
Replace CONTAINER in the command above with the actual PBA domain regsitration container name, e.g. ENOM, OPENSRS, GODADDY.

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