Article ID: 9712, created on Feb 18, 2011, last review on Oct 27, 2015

  • Applies to:
  • Odin Business Automation Standard

Symptoms

A customer has a subscription in Odin Business Automation Standard (OBAS).

The subscription period ended and a renewal order was generated for the customer but OBAS has not tried to pay and process the renewal order despite the fact that the customer has a valid credit card registered.

Cause

There may be several reasons why OBAS does not process the renewal order automatically:

  1. The subscription has a renewal policy set to "Generate renewal orders automatically but pay them manually" or "Do not generate renewal orders automatically". This means OBAS will not try to process a generated renewal order automatically. Instead, the customer (or a Provider on behalf of a customer) has to pay the renewal order manually.

  2. The customer does not have any Payment Methods configured and the customer's credit limit is not enough to pay the renewal order in question.

  3. The customer's credit card has the option "Use for recurring billing" disabled. This means OBAS will not try to use the credit card to automatically pay renewal orders. In this case, you'll see the follwoing error in the OBAS log:

    No recurring paymethod found
    
  4. The payment amount is more than the limit "The maximum amount for document to be paid recurrently" that is configured in OBAS. In this case, OBAS will not try to pay the renewal order automatically. The OBAS log (/var/log/hspc/hspc.log) will contain the error message:

    not paid, not collected enough payments 
    
  5. The document in question has its try count exceed "The maximum number of attempts to pay the document recurrently" value or "The maximum number of attempts to pay the document recurrently" is set to 0.

  6. The "Credit Card Processing" value is set to "Human-supervised" under Top > Commerce Director > Payment Processing > Secure Storage > General Settings tab

NOTE: Auto generated renewal orders are paid on subscription end date. That is by design, because if an order is paid earlier, subscription would be renewed before its end date.

Resolution

Provider can change the subscription renewal policy for a particular subscription in the Provider Control Panel:

  • Go to Top > Account Director > Subscription Manager > Subscriptions
  • Click on the required subscription
  • Click the "Edit" button
  • Set the renewal policy to "Generate renewal orders and try to pay them automatically"
  • Save changes

Customer may change the renewal policy for their subscription in their own control panel:

  • Go to My Account > Billing Management > Subscriptions
  • Click on the required subscription
  • Click the link "Renewal Settings"
  • Set the renewal policy to "Generate renewal orders automatically. I agree that renewal orders are to be paid automatically by my payment methods selected for recurring billing"
  • Save changes

Provider can also enable the option "Use for recurring billing" for a customer's credit card:

  • Go to Top > Account Director > Customer Manager > Customers
  • Click on the required customer
  • Switch to the "Payment Settings" tab
  • Click on the required credit card
  • Click the "Edit" button
  • Enable the option "Use this payment method for recurring payments"
  • Save changes

Customer can configure Payment Methods in the control panel:

  • Go to Account > Payment Methods > New Payment Method

Provider can define a special credit limit for the account the Order in question belongs to by going Top > Account Director > Customer Manager > Customers > Customer name, clearing the Use value of Credit Limit defined in Credit Terms box and entering the special credit limit value into the Credit Limit field. This solution is temporary, for when the new credit limit is overdrawn, Orders will stop provisioning.

Customer can enable recurring billing for their credit card in the control panel:

  • Go to My Account > Billing Management > Payment Methods
  • Select the required credit card
  • Click the "Edit" button
  • Enable the option "Use this payment method for recurring payments"
  • Save changes

Provider can increase the value of the parameter for the maximum amount to be paid recurrently, using the Provider Control Panel:

  • Go to Top > Commerce Director > Payment Processing > General Configuration
  • Click the "Edit" button
  • Adjust the value of the parameter "The maximum amount for document to be paid recurrently"
  • Save changes

Provider can increase the value of the parameter for the maximum number of attempts to pay the document recurrently, using the Provider Control Panel:

  • Go to Top > Commerce Director > Payment Processing > General Configuration
  • Click the "Edit" button
  • Adjust the value of the parameter "The maximum number of attempts to pay the document recurrently"
  • Save changes

To process orders automatically Provider can change the value of the parameter "Credit Card Processing" to "Automated":

  • Go Top > Commerce Director > Payment Processing > Secure Storage > General Settings tab
  • Click the "Edit" button
  • Set the value of the parameter "Credit Card Processing" to "Automated"
  • Save changes

See also

Orders are stuck in Paid status

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