Article ID: 9489, created on Dec 24, 2010, last review on May 4, 2014

  • Applies to:
  • Operations Automation

Symptoms


Open-Xchange provisioning tasks fail with the error message 'Primary mail address already exists in this context':
Task ID:    809957
Queue name:       aps_application_instance311
Task name: Executing configuration script for instance with id 311 of APS application with id 109
Task description:       Executing configuration script for instance with id 311 of APS application with id 109
Queue status:    
Failed
Start not earlier than:       Jul-08-2010 22:58
Last execution output:
Execution of configuration script for service instance with id 539 of instance with id 311 of application with id 109 failed - returned value: -1
output: 'Configure OX mail account context=78 'user@customer.com'
display name: User User
Primary mail address already exists in this context.
Failed to configure OX account context=78: 'user@customer.com': Primary mail address already exists in this context.
' errors: 'PHP Notice: Undefined index: W-SU in /usr/local/pem/APS/instances/311/scripts/utils.php on line 459
PHP Notice: Undefined index: W-SU in /usr/local/pem/APS/instances/311/scripts/utils.php on line 459
PHP Notice: Undefined index: W-SU in /usr/local/pem/APS/instances/311/scripts/utils.php on line 459
PHP Notice: Undefined index: W-SU in /usr/local/pem/APS/instances/311/scripts/utils.php on line 459
PHP Notice: Undefined index: W-SU in /usr/local/pem/APS/instances/311/scripts/utils.php on line 459'


Cause


This is known issue in Open-Xchange prior to 6.16.1.

Resolution


Upgrade Open-Xchange server to 6.16.1 or later.

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