Article ID: 8157, created on Mar 8, 2010, last review on Aug 12, 2014

  • Applies to:
  • Operations Automation

Symptoms

Open-Xchange task fails with the error message 'Invalid email address' like in the example below:
Task ID:        14212771
Queue name:     aps_application_instance63876
Task name:      Executing configuration script for instance with id 63876 of APS application with id 141
Task description:       Executing configuration script for instance with id 63876 of APS application with id 141
Queue status:   Failed
Start not earlier than:         Feb-16-2010 05:04
Last execution output:  
Execution of configuration script for APS application instance with id 63876 failed - returned value: 1 output: 'Connected successfully ID=62862
New context ID: 62862
Creating OX context 62862
Invalid email address
Failed to create OX context 62862: Invalid email address
' errors: ''


Cause


Email of Open-Xchange instance (subscription in POA terms) is incorrect.

One may check admin email in properties of failing task in POA Task Manager like in the example below:
env_var_SETTINGS_admin_email            jdoe@customer.com,  jdoe@customer.org
As it may be seen above the env_var_SETTINGS_admin_email parameter of APS task contains two emails - jdoe@customer.com and  jdoe@customer.org, this is wrong, that is why the task fails.

Resolution


Workaround is to remove one email address in the failing APS task parameters and re-run the task, use the Knowledgebase article How to change parameters of existing POA task to do that.

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