Article ID: 6395, created on Jun 3, 2009, last review on May 10, 2014

  • Applies to:
  • H-Sphere

Symptoms

Parallels H-Sphere mail server boxes can not pass PCI (payment card industry) scan in case there are PHP versions 4.* used.

Resolution

It is required to switch PHP to the version 5.* on Parallels H-Sphere

mail server boxes:

a). Enter the mail server box via ssh as root

b). Edit /hsphere/shared/scripts/scripts.cfg with your favorite editor

c). Change the following parameters values:

-apache_version=1

+apache_version=2

apache_mpm=prefork

-php_libphp5=0

-php_libphp4=2

-apache_libphp5=0

-apache_libphp4=1

+php_libphp5=2

+php_libphp4=0

+apache_libphp5=1

+apache_libphp4=0

apache_ssl=1

apache_scgi=0

apache_frontpage=0

 

where,

lines which begin with '-' are outdated;

lines which begin with '+' are with new/modified values;

rest lines are not changed.

 

d). Run restart apache script with 'force' option:

  /hsphere/shared/scripts/apache-restart force

 

e). Check if apache is running.

 

These will also switch to Apache version 2.*.

f213b9fa8759d57bee5d547445806fe7 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF