Article ID: 6017, created on Feb 5, 2009, last review on May 10, 2014

  • Applies to:
  • Helm 4


Parallels Helm 4.1, Parallels Helm 4.0


Parallels Helm depends on specific protection libraries which supplied with CLISecure protection tool. These libraries use some internal aspects of Microsoft .NET framework so every update/patch of .NET framework potentially can break these libraries functionality and in turn the Parallels Helm functionality.


After installing some Microsoft .NET framework update Parallels Helm may stop working at all.


As a workaround we recommend to configure Windows Automatic Updates as "Notify me but don't automatically download or install updates" on servers where  Parallels Helm is installed. This means that you will have possibility to test updates before installing them on production environment. If you have any doubts regarding particular update you can ask Parallels Helm support to confirm that such update safe or not. If you have lot of servers you can configure local automatic updates service WSUS ( which will allow to install automatically only those updates which you selected to install (verified on test environment or confirmed by Parallels Helm support).
To configure Automatic Updates you should open 

"Control Panel" -> "Windows Update" ->


"Notify me but don't automatically download or install updates" 
and then apply changes.
After that Windows will check for important updates and notify you if any are available; updates will be not delivered or installed on your computer until you choose to do so.For more details,  please read Microsoft documentation.

Note: To manually download and install updates, you must be a member of
the Administrators group for your computer.

0331e0e4efc12686c3f22fc2cdda9f03 152090ff5e9a05ea7e1cf0c248449638 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF