Article ID: 5996, created on Jan 30, 2009, last review on May 11, 2014

  • Applies to:
  • Helm 4

Symptoms

After installing Microsoft .NET Framework 3.5 Family Update (KB951847)
Parallels Helm stop working at all. Helm configuration tool does not
work as well.

AFFECTED VERSIONS

Parallels Helm 4.1, Parallels Helm 4.0

DESCRIPTION

The version of code protector (CLISecure) used for 4.1.0 and 4.0
versions of Parallels Helm is not compatible with KB951847 Microsoft
hot-fix.

WORKAROUND

If you have old version of Helm 4.0 (older than 4.0.20),  please download latest HelmConfigurationTool.exe version 4.0.20 (see in attachments) Copy/replace it to ...\Helm4\Tools folder.

Launch the Helm_KB951847_Patch.exe command line tool on the affected
server. This tool will fix the problem. It produces log file  (Helm_KB951847_Patch.log) which can be used to track patch process. If after this procedure Parallels Helm still does not work, launch  Configuration Tool (it should work) and perform Helm update.

Warning: Helm_KB951847_Patch.exe restart IIS

Attachments

0331e0e4efc12686c3f22fc2cdda9f03 152090ff5e9a05ea7e1cf0c248449638 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF