Article ID: 5515, created on Aug 1, 2008, last review on May 8, 2014

  • Applies to:
  • Odin Business Automation Standard 3.3

Cause

Malformed XML-API packet received by PBAS system may cause serious synchronization issues with Plesk nodes sending invalid/corrupted XML-API packets. Though Plesk validates XML before sending it out, enabling XSD validation in PBAS system should prevent any possibility of processing invalid/corrupted XML-API packets from Plesk nodes and notify Provider about such cases in Action log.

Resolution

To enable XSD validation for XML-API packets recevied from Plesk nodes please use the following steps:

  • ensure that libxml2 packet version installed inside PBAS Container is at least 2.6.16 version:# rpm -q libxml2
    libxml2-2.6.26-2.1.2.1
  • in case libxml2 version is older than 2.6.16 please update libxml2 package to more recent version using updates from vendor for corresponding OS distribution (using yum or rpm commands)
  • upgrade PBAS system to the latest available (at least 3.3.3-05) version
  • add the following line into /etc/hspc/hspc.conf configuration file:PLESK_XSD_VALIDATE = 1
  • restart PBAS backend to apply changes:# /etc/init.d/hspcd restart

With XSD validation enabled after receiving XML packets non-conforming to XSD schemas PBAS system will report failed action in Action log on Top > Action log screen and will ignore the API request/reply processing.

b91f0e51a581aafeed4e0834068081e0 400e18f6ede9f8be5575a475d2d6b0a6 95c731ef6bb58e30865e046f2135d4c1 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF