Article ID: 3992, created on Mar 7, 2008, last review on May 11, 2014

  • Applies to:
  • Pro Control Panel Linux 10.3.0


Product : Ensim Pro X for Linux
Version : 10.3.0
Topic : Hotfix
Addresses the following issue:
1. Site import fails with ValueError: need more than 2 values to unpack.
2. Unable to edit site properties from the Ensim Basic Control Panel.
3. Epld service not shutting down properly.


Version: 10.3.0 (Fedora Core 4, Fedora Core 6, Red Hat Enterprise Linux 4, Cent OS 4.4, Red Hat Enterprise Linux 5, Cent OS 5.0)

Date:  17-Oct-2007     

Issue: Site import fails with ValueError: need more than 2 values to unpack.
Resolution: This hotfix ensures the directories/files with newline characters are excluded when importing sites using the import function.

Issue: Unable to edit site properties from the Ensim Basic Control Panel.
Resolution: For basic license box, apply the hotfix and try to render the edit site page. This should not result in error.

Issue: Epld service not shutting down properly.
Resolution:  If epld restarted while backup process was running, it stops but did not start. This was because backup process ran with same process name as eplcp and epld assumed that eplcp was already running. This hotfix will check whether eplcp prcess is running already from /var/run/ file, instead of using ps command.



32bit OS
md5sum: f30ceb19b198cb39fd775381ec7642a2
md5sum: 7f6f20e538c136ebb591ae75bdd358ad

For FC6:

32bit OS
md5sum: efb1bcc2a633f89b10b086dd6940f606
md5sum: 794cd7bd9124522f4f39fd7d0bf53441

64bit OS
md5sum: cbb48a0da0be52eb30d97ab58b9f8d04
md5sum: 8b64a97b599ab0705e3e0453583003b5


32bit OS
md5sum: b77e7b799a8c6b79662194701be5106d
md5sum: 654e4b40d73df59213c346687ad1e251

64bit OS
md5sum: 86729db95f1cef79e3bcb529705b4ba3
md5sum: d3f28d92292884380014f71bfaaa239a


32bit OS
md5sum: b61e2a61da842212abb91c8edb42256d
md5sum: 620099cde22958e2287e00b6edc5db6c

64bit OS
md5sum: c9204917ea1a9504254936926a093345
md5sum: 41569b9c94665a9901f015c7ef9cb6d6


Before installing this hotfix, ensure that your have installed Hotfix 1:

Installation Procedure:

1. Upgrade the RPM.

    For FC4 (i386):
    rpm -Uvh epl-frontend-common-10.3.0-fc.4.17.i386.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-fc.4.17.i386.rpm 

    For FC6 (i386):
rpm -Uvh epl-frontend-common-10.3.0-fc.6.17.i386.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-fc.6.17.i386.rpm  

    For RHEL4 (i386):
    rpm -Uvh epl-frontend-common-10.3.0-rhel.4ES.17.i386.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-rhel.4ES.17.i386.rpm 

    For RHEL5 (i386):
    rpm -Uvh epl-frontend-common-10.3.0-rhel.5ES.17.i386.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-rhel.5ES.17.i386.rpm

    For FC6 (x86_64):
    rpm -Uvh epl-frontend-common-10.3.0-fc.6.17.x86_64.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-fc.6.17.x86_64.rpm 

    For RHEL4 (x86_64):
    rpm -Uvh epl-frontend-common-10.3.0-rhel.4ES.17.x86_64.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-rhel.4ES.17.x86_64.rpm 

    For RHEL5 (x86_64):
    rpm -Uvh epl-frontend-common-10.3.0-rhel.5ES.17.x86_64.rpm
    rpm -Uvh webppliance-virtualhosting-10.3.0-rhel.5ES.17.x86_64.rpm


Use RHEL4 rpms for CentOS4.4 and RHEL5 rpms for CentOS5

Post Installation Instructions:

1. Service epld restart

3ccb419cf98083f3bb45808fba8dbc7c 4cc899da08664637a8bc437308d3ddd7 3c1bb9f3c3b8305757c406e39a7aa454 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF