Article ID: 3885, created on Feb 8, 2008, last review on Apr 29, 2014

  • Applies to:
  • Helm 3

Resolution

Problem
 
When I try and create or delete a domain in Helm, it fails and in the error log, I get the following error:
 
Domain creation error:
 
2005-08-04 05:17:51 Website.IWeb_AddWebsite 0-2147467259: Unknown error while creating site: A name contained an invalid character.
{0}
2005-08-04 05:17:51 CWebsite.AddWebsiteEx 0-2147467259: Unknown error while creating site: A name contained an invalid character.
{0}
2005-08-04 05:17:51 CDomain.AddDomainEx 0-2147220477: Unknown error while creating site: A name contained an invalid character.
{0}
 
Domain deletion error:
 
2005-08-04 05:28:14 Website.IWeb_RemoveWebSite 0-2147467259: Unknown error while removing site: A name contained an invalid character.
{0}
2005-08-04 05:28:14 CWebsite.RemoveWebsiteEx 0-2147467259: Unknown error while removing site: A name contained an invalid character.
{0}
2005-08-04 05:28:14 CDomain.DeleteDomainEx 0-2147467259: Unknown error while removing site: A name contained an invalid character.
{0}
 
Solution
 
1.) Make sure that in IIS there are no websites set up like "Site #245" or "Site #388" - anything with the # symbol followed by a number. These are partially created sites that may cause issues with Helm. If there are sites like this, delete them from IIS (right-click the site and choose "Delete").
 
2.) Go to:
 
C:\\Helm.Config
 
and delete the IIS.xml file.
 
Now try and delete or create the domain you were previously having issues with. It should work. If not, contact your support provider.

110556ad4b9f1c73a3682661cd1dca89 152090ff5e9a05ea7e1cf0c248449638 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF