Article ID: 3845, created on Feb 8, 2008, last review on May 10, 2014

  • Applies to:
  • Helm 3


When trying to install FrontPage Extensions on a domain through Helm, it fails and I get the following error in the log:
2005-04-06 11:19:50 Website.IWeb_InstallFP Unknown error while installing FrontPage: The FP extension failed to install. FP Extensions responded: (-666) The server administration programs and the server extensions on the web server are not compatible. The administration program is too old to use with this server. ["C:\Program Files\WebHost Automation\Helm\\System\fpremadm.exe" -adminusername custadmin -adminpassword **** -targetserver http://SERVERIP:PORTNUMBER/fpadmdll.dll -o install -t iis -p 80 -sp publish -m -u custadmin]
This happens when the end user has uploaded their site using FTP prior to installing the extensions and while doing so has uploaded all of their "disk based web" extensions with it.

You would have to do one of two things:

1) Remove all of the customer's files from their website, install the FP Extensions through Helm, then have them publish their site using the FP Extensions.

2) Remove all of the files/folders that start with _vti from their site, and try installing the extensions then. This may not work every time, and its success depends on how many files this customer has on their site already.

The best route would to choose option 1. This may cause downtime for the end user, but it is the only way to guarantee that all of their FrontPage functionality is there with regard to their site and its functionality.

110556ad4b9f1c73a3682661cd1dca89 152090ff5e9a05ea7e1cf0c248449638 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF