Article ID: 3838, created on Feb 8, 2008, last review on May 10, 2014

  • Applies to:
  • Helm 3

Resolution

 
Problem
 
When I try to add or delete a domain, it fails and the following errors are found in the logs:
 
2005-03-04 13:10:42 Website.IWeb_AddWebsite Unknown error while creating site: The system cannot find the path specified.
2005-03-04 13:10:42 CWebsite.AddWebsiteEx Unknown error while creating site: The system cannot find the path specified.
2005-03-04 13:10:42 CDomain.AddDomainEx Unknown error while creating site: The system cannot find the path specified.
 
Solution
 
1.) Is the server that you are trying to create the domain on the Helm server, or a remote server? Whichever server it is, go to C:\Helm.Config and delete the IIS.xml file that is in there. Then try to create/delete the domain. Does the IIS.xml file get recreated? If not, it suggests that there is a permissions problem between the servers.
 
2.) The most common cause is when Microsoft's File and Print Sharing protocol becomes corrupt. You may need to reinstall it, but this is very simple:
 
- Go to Start > Control Panel > Network Connections
- Find the connection on your server that you have File and Printer Sharing enabled on, and right click and choose "Properties".
- Highlight "File and Printer Sharing for Microsoft Networks" and choose "Uninstall".
- You may need to reboot. If not, or after it has rebooted, go back to the network properties as above, and choose "Install". In the new window, highlight "Service" and click "Add". Select File and Printer Sharing from the list and choose OK.
- This will install File and Printer Sharing again. Make sure it is enabled, and try to add/delete a domain in Helm again.
 
3.) If neither of the above points helps, contact your support provider.

110556ad4b9f1c73a3682661cd1dca89 152090ff5e9a05ea7e1cf0c248449638 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF