Article ID: 3771, created on Feb 8, 2008, last review on May 11, 2014

  • Applies to:
  • Helm 3


When adding a MS SQL database to a domain, it fails and I get the following errors in the log:
2004-04-07 03:45:05 Microsoft OLE DB Provider for SQL Server [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
2004-04-07 03:45:05 CDatabase.CreateDatabaseEx [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
2004-06-11 17:19:09 Microsoft OLE DB Provider for SQL Server [DBNETLIB][ConnectionOpen (Invalid Instance()).]Invalid connection.
2004-06-11 17:19:09 CDatabase.CreateDatabaseEx [DBNETLIB][ConnectionOpen (Invalid Instance()).]Invalid connection.
1.) Make sure you have SQL Server installed on the server you have the SQL Server service setup on in Helm. Note: You cannot add databases using MSDE, as it is a single instance cut down version and does not provide this functionality. You need the full version of SQL Server in order to add databases.
2.) If the above is fine, then make sure that in the SQL Server service
(Home > System Settings > Servers > Your Server > SQL Service)
you have entered the SA username and correct password so that Helm can connect and create the database.
3.) If this is ok, then check in SQL itself. What you need is a default instance of SQL to be present (this is selectable from the actual install of SQL Server). For instance, you may have something like:
but no default instance, which would just be:
Without the default instance, Helm won't be able to access SQL Server to add databases.

152090ff5e9a05ea7e1cf0c248449638 110556ad4b9f1c73a3682661cd1dca89 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF