Article ID: 3541, created on Dec 28, 2007, last review on Aug 27, 2016

  • Applies to:
  • Operations Automation

Symptoms

A contact with external email address is created in the Exchange organization managed by OA (Enterprise-mode). If this contact is later used as the recipient of a message its email address is set to the value like this: cpa0001003662-12345x@d1003662.provider.tld

Such mail address may look unexpectedly for a customer.

Cause

HMC 4.0 for Exchange 2007/2010 does not allow external email address to be in the proxy address list because all proxy addresses should be system-wide unique, however there is no such guarantee in multi-tenant hosting environment. To comply with this requirement, the primary email address for an external contact is configured unique as '_cpa0001003662-12345x@d1003662.provider.tld', where 1003662 is the PA subscription ID, 12345 - unique ID for an external contact.

Resolution

OA is shipped with the special Address Rewriter Transport Agent to resolve the issue. With this agent installed on each server which has HUB role Exchange replaces primary email address in the 'To' and 'Cc' fields of the outgoing messages instead of targetEmail while sending email out of the system.

Note: email address like cpa0001003662-12345x@d1003662.provider.com will still be displayed in address list and within the contact information, it is only replaced with the original one while the message is leaving the Exchange system.

Refer to the OA Hosted Exchange Deployment Guide for the installation instructions:

Search Words

contact email address

Many of the Hosted Exchange customers are seeing strange email addresses in their address lists / ‘To’ field while sending emails.

contact with external email address

PBA generated email address

external contact email address displaying incorrectly

contact display name

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

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