Article ID: 3186, created on Nov 30, 2007, last review on May 11, 2014

  • Applies to:
  • H-Sphere 3.3
  • H-Sphere 3.4

Resolution

Supported Perl Versions

Below is the list of Perl packages required for H-Sphere correct work on supported operating systems. This list is valid for all H-Sphere versions before 2.5. Please make sure you have this version installed before you start installing or updating H-Sphere. To check the version of Perl installed on your box, run:

perl -V

WARNING: Do not update or change any configuration to your system Perl, as it will most likely damage your H-Sphere installation!

Operating System Supported Perl Version
HS 2.5+ HS before 2.5
Trustix Secure Linux 2.2 Perl 5.8.5, 5.8.7, 5.8.8 Perl 5.8.5; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
Trustix Secure Enterprise Linux release 2 Perl 5.8.3, 5.8.7, 5.8.8 Perl 5.8.3; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
RedHat Linux 7.2, RedHat Enterprise Linux (AS/WS/ES) Perl 5.6.1, 5.8.7, 5.8.8 Perl 5.6.0 for non-mail boxes
Perl 5.6.1 on mail boxes. Perl update is made automatically by the H-Sphere install or update script for the hsphere-mail-service package with SpamAssassin 3.0.1 and up); 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
RedHat Linux 7.3 Perl 5.6.1, 5.8.7, 5.8.8 Perl 5.6.1; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
RedHat Enterpise Linux 3, CentOS 3.x, White Box Enterprise Linux 3.x Perl 5.8.0, 5.8.7, 5.8.8 Perl 5.8.0; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
RedHat Enterpise Linux 4, CentOS 4, White Box Enterprise Linux 4 Perl 5.8.5, 5.8.7, 5.8.8 Perl 5.8.5; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
FreeBSD 4.x Perl 5.8.0; 5.8.5; 5.8.7, 5.8.8 Perl 5.8.5 on mail boxes. Perl update is made automatically by the H-Sphere install or update script for the hsphere-mail-service package with SpamAssassin 3.0.1 and up; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
FreeBSD 5.3 Perl 5.8.5, 5.8.6, 5.8.7, 5.8.8 Perl 5.8.5; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater
FreeBSD 5.4 Perl 5.8.6, 5.8.7, 5.8.8 Perl 5.8.6; 5.8.8 for HS 2.4.3 Patch 11+ with hsphere-perl package installed by running package updater

f213b9fa8759d57bee5d547445806fe7 f90e90e234d2835301363089f6b828e5 6311ae17c1ee52b36e68aaf4ad066387 3fce07d43dd909dcf7cad8a0e8c377eb

Email subscription for changes to this article
Save as PDF