Article ID: 2812, created on Oct 29, 2007, last review on Apr 18, 2012

  • Applies to:
  • Pro Control Panel Linux


View Knowledge
Knowledge ID 2215
Product : Ensim Pro for Linux
Version : 4.1.0
Topic : Hotfix

List of packages that should not be upgraded on an Ensim server.

List of packages that should not be upgraded on an Ensim Pro for Linux 4.1.0 server.



OS versions: RHEL ES 3/4, CentOS 4.2, FedoraCore 1/2

Background: Ensim Pro comes packaged as RPMs that contain a) control panel frontend (this is the GUI), b) control panel backend engine (backend that communicates with applications) and c) applications in the form of RPMs (web, ftp, mail, etc.).

Ensim RPMs you should leave alone: Some of these application RPMs have an Ensim tag in the build number ("ensimized RPMs"). This denotes that Ensim has made modifications to the RPM for various reasons such as fixing bugs, adding additional security, or improving performance for hosting domains.  The detailed list of these RPMs is shown below.


Rpms that should not be upgraded Why?

- added additional info (referrer)

- changed default ownership of files to root


- turned the tarball into an RPM

- bug fixes (date/time format of log filenames)

frontpage turned the tarball into an RPM

- modified configuration file

- added security fixes

- modified build so it may be built by non-root

mod_jk modified to be better integrated with apache
poprelay created an RPM for the script
phpMyAdmin turned the tarball into an RPM
proftpd-[package] turned tarball into an RPM
sqmail Ensimised
tomcat4 turned tarball into an RPM
uw-imap Ensimised
vacation turned tarball into RPM
zope-[package] changed the default RPM build from using python 1.5.2 to python 2.2
Pine (MUA) Ensimised
glibc may create problems with services like sshd,sendmail,proftpd etc

To make the skip list configuration in /etc/yum.conf add the following line:
exclude=  tomcat4* proftpd* postgres* majordomo* analog* squirrelmail* frontpage* vacation* pine* phpMyAdmin* uw-imap*  mod_jk* zope* poprelay* cronolog* glibc*

Note: 1. Upgrading OS using yum is not tested and supported by Ensim. We recommend you that do not upgrade the OS using yum.

2. When upgrading postgres package you will need to follow the upgrade steps mentioned by the postgres.

3. For upgrading packages like sendmail, bind, httpd please contact Ensim Support to get more details about upgrade.


Related Knowledge

Related Links
Last ModifiedUsageSatisfiedLast Used
10/8/2006 8:22:08 PM3667510/11/2007 4:31:13 AM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF