Article ID: 2745, created on Oct 29, 2007, last review on May 10, 2014

  • Applies to:
  • Pro Control Panel Linux


View Knowledge
Knowledge ID 2063
Product : Ensim Pro for Linux
Version : 4.0.3
Topic : Apache

Enabling PHP-GD for Ensim Pro for Linux 4.0.3 for FC1 after upgrade from 4.0.2

PHP-GD gets disabled when upgrading to appliance version 4.0.3 for Fedora Core1.



Products affected:
Ensim Appliance Version 4.0.3 for FC1 with php 4.3.10 after upgrade from Ensim 4.0.2.



When Ensim Appliance 4.0.2 with php 4.3.10 is upgraded to Ensim Appliance 4.0.3 for FC1, the file is updated and skips to include the rpm for php-gd, php-ncurses and php-mbstring. So these applications remain enabled for the server but the libraries for the same do not propagate to the the virtual  sites causing the applications to be disabled for all sites.


To fix this issue you will need to copy the attached file to the location /etc/virtualhosting/filelists and run the system thru maintenance mode

To run the system thru maintenance mode

- set_pre_maintenance

- set_maintenance

- set_post_maintenance

- service webppliance restart


The time required for maintenance mode would depend upon the number of domains on your server, approximately it requires 1 minute per domain. Also do not interrupt or stop maintenance mode as it may crash your webppliance.


Related Knowledge

Related Links
Last ModifiedUsageSatisfiedLast Used
12/23/2005 1:08:09 AM295 10/11/2007 2:12:14 AM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF