Article ID: 2710, created on Oct 29, 2007, last review on Apr 17, 2012

  • Applies to:
  • Pro Control Panel Linux


View Knowledge
Knowledge ID 1981
Product : EnsimPro on Linux(Fedora)
Version : 4.0.3
Topic : Hot Fix

Hotfix : Multiple Issues Addressed

Following issues are fixed :
sperl buffer overflow error
php vulnerability fix



Product: Ensim Pro and Basic for Linux
Platform: SSH (Small Scale Hosting) only i.e ONLY for LS (standalone) customers.
Version:4.0.3 (Fedora Core 1)                  
Date: April 20, 2005
Patch Description: Address two issues :

  • sperl buffer overflow error
  • php vulnerability fix


Installation Instructions:

wget -q

tar -xvzf php-4.3.0-1.1.tar.gz

cd php-4.3.0-1.1

rpm -Uvh *

Run the following set of commands after installing the rpm:

   1. set_pre_maintenance

   2. set_maintenance

   3. set_post_maintenance

   4. service webppliance restart

Note: ensim-appliance-l-4.0.3-25.fc.1.i386.rpm obsoletes perl-suidperl as a fix for the sperl security vulnerability


Related Knowledge

Related Links
Last ModifiedUsageSatisfiedLast Used
4/25/2005 11:13:51 PM176 10/15/2007 11:33:42 PM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF