Article ID: 2560, created on Oct 29, 2007, last review on Apr 30, 2014

  • Applies to:
  • Pro Control Panel Linux

AdditionalInformation

View Knowledge
Knowledge ID 1706
Product : WEBppliance for Linux
Version : 3.1.1
Topic : FAQ

Title
When I try upgrading to WEBppliance 3.1.1 for Linux, I receive an RPM dependency

Summary
When I try upgrading to WEBppliance 3.1.1 for Linux, I receive an RPM dependency error

Prevention


Details

When upgrading to WEBppliance 3.1.1, you may recieve an RPM dependency error such as this:
 
openssh = 3.1p1-6 is needed by openssh-askpass-3.1p1-6
libcrypto.so.1 is needed by openssh-3.4p1-1
libcrypto.so.1 is needed by openssh-clients-3.4p1-1
libcrypto.so.1 is needed by openssh-server-3.4p1-1

To fix this:
 
1) Either obtain or build an openssh RPM with the same version number that is compatible with Red Hat 7.2 and newer than the one provided by WEBppliance 3.1.1.
 
2) Place the RPMs in the /tmp/extrarpms directory before running wpinstall-u.sh.
 
READ THE FOLLOWING CAREFULLY
 
During testing, Ensim has found that some customers have upgraded certain services such as PHP and OpenSSH to newer versions than provided by 3.0.3 or 3.1.0.  This can have upgrade implications for 3.1.1 as stated above.  Ensim has placed some unsupported RPMs on its FTP site to help these customers who may not know how to build or find the RPMs to complete the upgrade. These RPMs are not supported, and Ensim will not accept any support tickets regarding these RPMs or any problems that arise from using these RPMs.You can find these RPMs at:
 
ftp://ftp.ensim.com/outgoing/patches/webppliance/not-supported

For any other RPM dependency issues, obtain the RedHat 7.2 compatible RPM and place it in /tmp/extrarpms.


Attachments


Related Knowledge

Related Links
 
Last ModifiedUsageSatisfiedLast Used
8/20/2004 12:33:45 PM30 10/11/2007 6:51:35 AM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF