Article ID: 2378, created on Oct 29, 2007, last review on May 11, 2014

  • Applies to:
  • Pro Control Panel Linux

AdditionalInformation

View Knowledge
Knowledge ID 1135
Product : WEBppliance for Linux
Version : 3.5.19
Topic : Hot Fixes

Title
Update openssl Security Fix for WEBppliance Pro and Basic for Linux 3.5.19

Summary
Update openssl Security Fix for WEBppliance Pro and Basic for Linux 3.5.19

Prevention


Details
Solution:


Title: Updated openssl packages fix security issues

Advisory: RHSA-2003:291-01

Affected Products: WEBppliance Pro for Linux 3.5.19, WEBppliance Basic for Linux 3.5.19

Details: Updated openssl packages fix security issues. For more details on the security issues please refer to https://rhn.redhat.com/errata/RHSA-2003-291.html 


RPM Packages:

Please download the following RPMS and refer to the installation section for installation instructions.

For WEBppliance Pro for Linux 3.5.19, download these from http://download.swsoft.com/ensim/download/webppliance/linux/Pro/3.5.19/errata/errata-openssl/

openssl-0.9.6b-35.7.i386.rpm                   
openssl-devel-0.9.6b-35.7.i386.rpm                             
openssl-perl-0.9.6b-35.7.i386.rpm                      
webppliance-siteinfo-3.5.19-8.i386.rpm
webppliance-epilog-3.5.19-8.i386.rpm           
webppliance-prolog-3.5.19-8.i386.rpm           
openssl096-0.9.6-23.7.i386.rpm
virtualhosting-fst-siteinfo-3.5.19-8.i386.rpm

For WEBppliance Basic for Linux 3.5.19, download these from http://download.swsoft.com/ensim/download/webppliance/linux/Basic/3.5.19/errata/errata-openssl/

openssl-0.9.6b-35.7.i386.rpm                   
openssl-devel-0.9.6b-35.7.i386.rpm                             
openssl-perl-0.9.6b-35.7.i386.rpm                      
webppliance-siteinfo-3.5.19-8.i386.rpm
webppliance-epilog-3.5.19-8.i386.rpm           
webppliance-prolog-3.5.19-8.i386.rpm           
openssl096-0.9.6-23.7.i386.rpm
virtualhosting-fst-siteinfo-3.5.19-8.i386.rpm


Installation Instructions

WARNING: Please make sure that your WEBppliance Pro/Basic is at version 3.5.19 before applying this security fix.

WEBppliance Pro and Basic for Linux (LS)

NOTE: Ensure LWP 3.5.19-5 is installed with Security patches updates of 3.5.19 Errata (Apache-modssl, Perl and proftpd)

Once you have downloaded these rpms into a single directory run the following commands:
rpm -Fvh *rpm
/etc/rc.d/init.d/webppliance restart

WEBppliance Pro and Basic for Linux (LH)

Please refer to http://onlinesupport.ensim.com/TWKB/Viewcase.asp?QSRuleID=821 now to use these RPMS to revise your WEBppliance.


Attachments


Related Knowledge

Related Links
 
Last ModifiedUsageSatisfiedLast Used
8/20/2004 12:56:10 PM23 10/11/2007 6:14:14 AM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF