Article ID: 2369, created on Oct 29, 2007, last review on Apr 16, 2012

  • Applies to:
  • Pro Control Panel Linux


View Knowledge
Knowledge ID 1123
Product : WEBppliance for Linux
Version : 3.5.17
Topic : FAQ

Domains created by a reseller do not show up for the reseller

Domains created by a reseller do not show up for the reseller



When the Appliance Administrator makes any changes to the default plan, because Reseller is left as None, WEBppliance will disable reseller in the default plan.

If you look at /etc/virtualhosting/plans/default/reseller you will see that it has two items:

enabled = 0
reseller_id = 0

To repair so that new sites created have proper reseller configuration, edit /etc/virtualhosting/plans/default/reseller and configure as:

enabled = 1
reseller_id = 0

Next, you will need to edit all plans created by the affected resellers and repair their reseller config.  You will need to identify the "reseller" number of the reseller.  This is the same as the numeric value of the reseller's directory located in /home/reseller.  For example, reseller 6 is located in /home/reseller/6

To repair the reseller's plans so that new sites have proper reseller configuration , edit /home/reseller/*/plans/*/reseller and configure as:

enabled = 1
reseller_id = NNN

...where NNN is the reseller_id you have identified for each reseller.

The last step is to fix all existing sites. Login to the appliance administrator and re-assign the sites to the appropriate resellers in the Site Manager which have this problem.


Related Knowledge

Related Links
Last ModifiedUsageSatisfiedLast Used
8/20/2004 12:59:05 PM29 10/11/2007 6:11:07 AM

4cc899da08664637a8bc437308d3ddd7 3ccb419cf98083f3bb45808fba8dbc7c 6311ae17c1ee52b36e68aaf4ad066387

Email subscription for changes to this article
Save as PDF