Search Engine: Elastic

Article ID: 132760, created on Jun 9, 2018, last review on Jun 9, 2018

  • Applies to:
  • Operations Automation
  • Business Automation

Symptoms

Sometimes it is possible to observe the following error message either in a billing control panel or when caling some API method:

maximum number of workers registered

Cause

A lot of calls (250+) that return an object of type ListResult was received by a billing server within a short period of time (2 minutes). To improve this scenario, an internal request PBA-85016 was submitted to the development team. Contact the Technical Account Manager or Pooled Technical Associate Team at pta@odin.com to clarify the status of this request.

Resolution

The only available for this moment solution is to wait at most 2 minutes until the billing application removes unneccessary objects by itself. If a root cause is related to an external system that makes a big amount of API calls, then it is required to rework its design to avoid massive invocation of API methods.

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