Search Engine: Elastic

Article ID: 132273, created on Feb 20, 2018, last review on Apr 13, 2018

  • Applies to:
  • Business Automation

Symptoms

On attempt to remove a Tax Zone of a particular vendor or a provider, one can see an error message:

Tax Zone {...} cannot be removed. Please first remove remove the {...} assigned to this Tax Zone.

However, the account has no Taxation Rules or Tax Zone Assignment Rules referencing the deleting Tax Zone.

Cause

One or more vendor has a Taxation Zone with the same name and there is some taxation object (like Taxation Rule or Tax Zone Assignment Rule) that references that zone. Due to the software-related issue #PBA-67935 "Unable to remove Tax Zone if zone with same ID is used under different vendor", it is impossible to delete a Tax Zone if there are objects linked to a zone with the same name even if it belongs to another account.

Resolution

  1. Go to Home > System > Settings > Taxation > Tax Zones and Tax Categories > Tax Zones and check if a Tax Zone with the same ID exists under other vendor;
  2. If such zone exists, it is required to look for any Taxation object that could be linked to the zone. Such objects include:
    • Tax Zone Assignment Rules at Home > System > Settings > Taxation > Tax Zones and Tax Categories -> Tax Zone Assignment Rules: reassign the rule to another zone or remove the rule;
    • Taxation Rules at Home > System > Settings > Taxation: remove the rule;

Contact your Technical Account Manager or Pooled Technical Associate team at pta@odin.com to clarify the current status of PBA-67935.

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF