Search Engine: Elastic

Article ID: 131762, created on Nov 10, 2017, last review on Nov 10, 2017

  • Applies to:
  • Operations Automation
  • Business Automation 6.0
  • Odin Automation Essentials 7.1

Symptoms

An Order for Office 365 service fails:

The last error - "Service Creation Failed: Parallels Operations Automation error #error_code #0, extype_id #1, module_id #Common, Internal error: APSC: Invalid partnerId: 1234.</code></pre>

sitelog error:

ERROR flow        : Caught unknown error:
Code:           '3000'
Message:        'Invalid partnerId: 1234'
Partner Exception:
property_name: advisor_partner_id

Context: Request Id: 5c07f57a-3d5f-46d4-ab4d-9264c57afeb4, Correlation Id: 5c07f57a-3d5f-46d4-ab4d-9264c57afeb4, Locale: en-US
Base Description: Microsoft.Store.PartnerCenter.Exceptions.PartnerException: Invalid partnerId: 1234

Cause

There are two possible reasons:

  1. If mentioned identifier is zero - Invalid partnerId: 0 - this behavior is addressed to Odin Development team as Request #APSA-18944: "Office 365 task fails with: "Invalid partnerId: 0".
  2. If mentioned identifier is not zero - Invalid partnerId: 1234 - invalid MPN_ID attribute is specified for Reseller on the Billing side.

Resolution

Please contact pta@odin.com or TAM to trace the status of the request.

In case invalid MPN_ID is specified - please contact Microsoft support in order to obtain correct PartnerId value and specify it as Billing Attribute.

e2dd85103e4d5b8ef7231deccb87506e caea8340e2d186a540518d08602aa065 d29f8259a7236d291b08be8147a45abd 198398b282069eaf2d94a6af87dcb3ff e12cea1d47a3125d335d68e6d4e15e07 3627d36199b8ff577605df76e2fa222b bb7e9177fb03488961a3ea554120f328 5356b422f65bdad1c3e9edca5d74a1ae

Email subscription for changes to this article
Save as PDF