Search Engine: Elastic

Article ID: 131139, created on Jul 13, 2017, last review on Aug 24, 2017

  • Applies to:
  • Operations Automation 7.0
  • Operations Automation 7.1

Symptoms

An attempt to open VE Console fails with the following error message appearance:

Unable to open the server console. Please try again. If the problem persists, please contact your system administrator for assistance.

Even though the required network interface is present, the following error can be observed in /var/log/pa/vps.vm2vf.log:

2017-07-07 10:20:30,557 (12345-abcd-1234-abcd-123456abc start_console_cb callback) INFO  LogConfigureConsoleCallback [Thread-2111] - INF callback: job [__PrlSrv_GetSrvConfig] cbp 0x7f9e3c035990 index [70] h type [PHT_JOB/] h/job [0x10339/0x10339] (configure_console_cb, console.c, 349) @[common/generic_sdk_cb.c][343][generic_sdk_cb][206793])
2017-07-07 10:20:30,557 (12345-abcd-1234-abcd-123456abc start_console_cb callback) INFO  LogConfigureConsoleCallback [Thread-2112] - INF callback: job [__PrlSrv_GetSrvConfig] index [70] PASSED @[common/generic_sdk_cb.c][386][generic_sdk_cb][206793])
2017-07-07 10:20:30,560 (12345-abcd-1234-abcd-123456abc start_console_cb callback) ERROR LogConfigureConsoleCallback [Thread-2113] - ERR network adapter (br1) not found: failure PRL_ERR_NETWORK_ADAPTER_NOT_FOUND @[console.c][123][get_vnc_host_port][206793])
2017-07-07 10:20:30,560 (12345-abcd-1234-abcd-123456abc start_console_cb callback) ERROR LogConfigureConsoleCallback [Thread-2114] - ERR get_vnc_host_port(configure_console_cb, console.c, 349): failure: PRL_ERR_NETWORK_ADAPTER_NOT_FOUND @[common/generic_sdk_cb.c][424][generic_sdk_cb][206793])

Hardware Node has Virtuozzo version 7 installed.

Cause

This behavior is caused by several software-related issues:

#CCU-14821 "[vz7] vnc console do not open"

#CCU-15520 "[VZ] VNC console not working for VMs in VZ7"

Resolution

This issue is going to be fixed in 7.1 and later versions. In 7.1, it will be fixed by releasing the hotfix but be aware that this will be working only for new VEs created after the installation of hotfix. To fix the issue with console for the already existed VEs in 7.1 before applying the hotfix, you can do the following:

  1. Log in to the VZ7 node.
  2. Virtuozzo 7 has a restriction to change settings of the started VEs, therefore first stop it, apply changes and start it afterwards:

    prlctl stop <VE>
    prlctl set <VE> --vnc-mode auto –vnc-passwd <RANDOM PASSWORD>
    prlctl start <VE>
    

0871c0b47b3b86ae3b1af4c2942cd0ce caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5356b422f65bdad1c3e9edca5d74a1ae 1941880841f714e458ae4dc3d9f3062d 8c199f0ee4305da1a577740620df4a51

Email subscription for changes to this article
Save as PDF