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Article ID: 131004, created on Jun 15, 2017, last review on Jun 15, 2017

  • Applies to:
  • Operations Automation

Symptoms

Office 365 Synchronization fails with the following error:

"An item with the same key has already been added"

In CCPv2 users like user1@domain.com and user1@domain.onmicrosoft.com appear as duplicates.

O365 Endpoint database contains duplicate entries with the same UserObjectId in User table:

PrincipalName   FirstName       LastName        DisplayName     UserObjectId
user1@domain.onmicrosoft.com John       Doe   John Doe CCDEF871-E714-48A7-945C-B08802FB69C5
user1@domain.com      John  Doe   John Doe    CCDEF871-E714-48A7-945C-B08802FB69C5

Cause

In certain scenarios, same user could be added to OA with onmicrosoft.com prefix and without it. Such situation is prevented, starting from O365 APS application version 16.8.6. The issue is registered with internal ID APSA-18040.

Resolution

Contact Odin Technical Support to apply the solution.

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