Article ID: 130692, created on Apr 21, 2017, last review on May 22, 2017

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

Overusage invoices are not generated for Plesk subscriptions in OBAS. The statistic is collected and stored correctly on Plesk side.

Cause

OBAS can not validate the response from a Plesk node during statistic collection task. The following records can be found in /var/log/hspc/hspc.log:

[2017/01/23 04:22:16] [INFO] [2487] [HSPC::MT::Plesk::PleskGate::__send_request_to_agent] Validation of XML document against XSD Schema failed:unknown-2b600a60:0: Schemas validity error : Element 'mbox-quota': '5368709120' is not a valid value of the atomic type 'unsignedInt'.
unknown-2b600a60:0: Schemas validity error : Element 'mbox-quota': '8589934592' is not a valid value of the atomic type 'unsignedInt'.
unknown-2b600a60:0: Schemas validity error : Element 'mbox-quota': '8388608000' is not a valid value of the atomic type 'unsignedInt'.
unknown-2b600a60:0: Schemas validity error : Element 'mbox-quota': '5368709120' is not a valid value of the atomic type 'unsignedInt'.
unknown-2b600a60:0: Schemas validity error : Element 'mbox-quota': '5242880000' is not a valid value of the atomic type 'unsignedInt'.
unknown-2b600a60:0: Schemas validity error : Element 'mbox-quota': '10737418240' is not a valid value of the atomic type 'unsignedInt'.

As a result statistic collection task fails:

[2017/01/23 04:22:16] [DEBUG] [2487] [HSPC::WebDB::select_run] INSERT INTO `action_log` (`email`,`username`,`error_code`,`result`,`node2_id`,`account_no`,`node2_type`,`node_name`,`module_id`,`finished`,`problem_id`,`node_id`,`ip_address`,`node_type`,`action_id`,`comment`,`started`,`node2_name`) VALUES ('','','1','1',NULL,NULL,'','plesk.server.tld','55',NULL,NULL,'174','127.0.0.1','HSPC::MT::OM::HN','31','Failed to valide XML response from Plesk node: unknown-2b600a60:0: Schemas validity error : Element ''mbox-quota'': ''5368709120'' is not a valid value of the atomic type ''unsignedInt''.

[2017/01/23 04:22:16] [INFO] [2487] [HSPC::MT::Plesk::Collector::_update_plesk_client_statistics] Error occurred during get info from Plesk node
[2017/01/23 04:22:16] [DEBUG] [2487] [HSPC::MT::Plesk::Collector::_update_plesk_client_statistics] TRACE [03]: . . -> HSPC::MT::Plesk::Collector->_update_plesk_client_statistics (hn_id => 174)

Such behavior was classified as software issues PPPM-5386 from Plesk side and PBAS-30538 from Odin side. PBAS-30538 was fixed in OBAS 4.5.7 release.

Resolution

To resolve the issue, please upgrade to 4.5.7 as described in How to upgrade OBAS system to the latest available version.

Hotfix for OBAS 4.5.6

Note: before applying the hotfix please make sure that Plesk issue PPPM-5386 is fixed on all registered Plesk nodes.

If upgrade is not an option for you, there is a hotfix for 4.5.6 version. You can download 64-bit hotfix or 32-bit hotfix depending on your OS and install it by running the commands below.

For 64-bit OS:

# rpm -Uvh  hspc-plesk-4.5.6-59.swsoft.x86_64.rpm

# service hspcd restart

For 32-bit OS:

# rpm -Uvh hspc-plesk-4.5.6-59.swsoft.i386.rpm

# service hspcd restart 

Warning: Restart of the hspcd service will cause OBAS downtime for about 10-60 seconds.

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