Article ID: 129568, created on Oct 8, 2016, last review on Oct 8, 2016

  • Applies to:
  • Business Automation 6.0

Symptoms

GeoIP plugin check did not correctly apply the fraud rule, in BA logs the following error can be found:

[DATE_TIME GEOIPBM_Obj RQXXXXX THXXXXX TRC]      ...[5] *** INTERRUPTED BY EXCEPTION *** ItemResult* GEOIPBM::CheckCondition(Int, Int)
[DATE_TIME GEOIPBM_Obj RQXXXXX THXXXXX NTE] Finished method GEOIPBM.CheckCondition(user = -1, SID = 0, lang = en, request = 0, localObject = 1, transaction = XXXXX (HP))
[DATE_TIME GEOIPBM_Obj RQXXXXX THXXXXX NTE]         ExceptionResult: Cannot access to GeoIP database.

Cause

GeoIP plugin misconfiguration. As per documentation in /usr/local/bm/etc/ssm.conf.d/global.conf file path_geoip_db variable should have full path to the folder where new GeoIP database is located however full path to new db is specified:

# cat /usr/local/bm/etc/ssm.conf.d/global.conf
...
path_geoip_db = /some_path/directory/GeoIP.dat

Resolution

Change the configuration in /usr/local/bm/etc/ssm.conf.d/global.conf file to:

# cat /usr/local/bm/etc/ssm.conf.d/global.conf
...
path_geoip_db = /some_path/directory

Search Words

Cannot access to GeoIP database

GeoIP

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 3627d36199b8ff577605df76e2fa222b bb7e9177fb03488961a3ea554120f328

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