Article ID: 129280, created on Aug 20, 2016, last review on Aug 20, 2016

  • Applies to:
  • Business Automation

Symptoms

The following responce is received after API call:

<methodResponse>
   <fault>
      <value>
         <struct>
            <member>
               <name>faultCode</name>
               <value>
                  <i4>-1</i4>
               </value>
            </member>
            <member>
               <name>faultString</name>
               <value>
                  <string>System Error
Object is not available inside a server</string>
               </value>
            </member>
         </struct>
      </value>
   </fault>
</methodResponse>

Cause

If atm container is restarted (for example killed by OOM killer and then started by watchdog), xmlrpcd stops working and need manual restart.

Resolution

The issue has been assigned ID PBA-49400 and fixed in BA version 5.5.2

As a workaround, xmlrpcd service should be restarted:

service pba restart xmlrpcd

Search Words

inside a server

api faultString

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07

Email subscription for changes to this article
Save as PDF