Article ID: 129205, created on Aug 2, 2016, last review on Aug 2, 2016

  • Applies to:
  • Operations Automation 6.0

Symptom

OA updates installer throws an error (version check failed) on precheck stage in case of batch updates installation:

2015-07-28 17:44:48.848 ERROR <class 'poaupdater.uPrecheck.PrecheckFailed'> Precheck error: Not all requirements satisfied: following updates are not installed:poa-6.0-3517_update04-317
You should: Install missing updates
...
2015-07-28 17:44:48.849 ERROR
at checkRequirements (/usr/local/pem/var/updates/poa-6.0-3517_update04_KB126204-precheck/poaupdater/uPEM.py :711) in raise uPrecheck.PrecheckFailed("Not all requirements satisfied: following updates are not installed:%s" % ', '.join(not_installed), "Install missing updates")
at <lambda> (/usr/local/pem/var/updates/poa-6.0-3517_update04_KB126204-precheck/precheck.py :36) in prepare_actions.insert(0, uDLModel.FuncAction("Check build version requirements", lambda: uPEM.checkRequirements(build_info)))
at execute (/usr/local/pem/var/updates/poa-6.0-3517_update04_KB126204-precheck/poaupdater/uDLModel.py :37) in return self.func()
at performActions (/usr/local/pem/var/updates/poa-6.0-3517_update04_KB126204-precheck/poaupdater/uAction.py :213) in action.execute(readonly = True, precheck = True)

Cause

OA updater checks OA version for both major OA update and its hotfixes. Hotfixes require major update version to be installed and therefore the error is thrown.

Resolution

Such behavior is correct, and it will not interrupt the installation of OA updates.

Search Words

Precheck error: Not all requirements satisfied: following updates are not installed:

OA updater

You should: Install missing updates

OA update installation

Not all requirements satisfied:

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF