Article ID: 129194, created on Aug 1, 2016, last review on Aug 1, 2016

  • Applies to:
  • Operations Automation 7.0

Symptoms

OSA has been upgraded from 6.0 to 7.0.

Cloud Infrastructure module was deployed earlier on version 6.0.

On an attempt to add Instance Manager node, a related task fails with the following error message:

Native dependency processing failed; list of dependences: PACI-im >= 1.4-600:PACI-vm2vf >= 1.4-600:terracotta >= 3.6.1-392:PACI-prl-sdk >= 1.4-135:jre = 1.6.0_45-fcs:sshpass >= 1.05-1. Please either install the packages above, or application templates with them. Error: /usr/local/pem/sbin/pem-pkg-tool:21: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module.
import popen2
Missing or unsatisfied requirements: { PACI-vm2vf (>=1.4-600), terracotta (>=3.6.1-392), PACI-im (>=1.4-600) }.

Cause

CCU-13069 OACI related PPMs of 6.0 version are left in PPM repository and are getting picked up for IM deployment.

ppms

Resolution

Remove all PACI* PPMs of 6.0 version from package repository at Infrastructure -> Package Repository.

Search Words

Native dependency processing failed; list of dependences: PACI-im >= 1.4-600:PACI-vm2vf >= 1.4-600:terracotta >= 3.6.1-392:PACI-prl-sdk >= 1.4-135:jre = 1.6.0_45-fcs:sshpass >= 1.05-1. Please either install the packages above, or application templates with them. Error: /usr/local/pem/sbin/pem-pkg-tool:21: DeprecationWarning: The popen2 module is deprecated. Use the subprocess module. import popen2 Missing or unsatisfied requirements: { PACI-vm2vf (>=1.4-600), terracotta (>=3.6.1-392), PACI-im (>=1.4-600) }.

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 0871c0b47b3b86ae3b1af4c2942cd0ce 1941880841f714e458ae4dc3d9f3062d

Email subscription for changes to this article
Save as PDF