Article ID: 128870, created on May 26, 2016, last review on May 26, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

When under Top > Account Director > Subscription Manager > Subscriptions > Subscription name the Terminate button is pressed, nothing happens. The subscription stays in Active status.

Cause

When a subscription is terminated all of its open orders are cancelled. If an order cannot be cancelled for some reason, termination is impossible. To find more details, please check DEBUG OBAS log (/var/log/hspc/hspc.log) for errors like

[2016/05/26 14:18:53] [DEBUG] [24521] [HSPC::Logger::sw_trace] TRACE [04]: . . . +> cancelling order # 12345, doc_status=>R
[2016/05/26 14:18:53] [INFO] [24521] [HSPC::MT::Billing::Ar_doc::unadjust_payment_documents] Loading adjusting document ID=12346
[2016/05/26 14:18:53] [FATAL] [24521] [Error::throw] Adjusting document has CANCELED status. This payment should be unadjusted by now!

Resolution

In the case above, a Cancelled Invoice #12346 is attached to a Paid Order #12345:

Top > Billing Director > Receivable > Documents > Orders > Order #12345 Paid
Top > Billing Director > Receivable > Documents > Invoices > Invoice #12346 Cancelled

To resolve the issue, please cancel the Order #12345 and proceed to terminating the subscription.

See also

Subscriptions in Termination Queue lack functionality

Terminating Subscriptions

Search Words

Adjusting document has CANCELED status. This payment should be unadjusted by now!

unable to terminate

624ca542e40215e6f1d39170d8e7ec75 caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e

Email subscription for changes to this article
Save as PDF