Article ID: 128865, created on May 25, 2016, last review on May 25, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

There is a wrong A record in a domain DNS zone. The domain is used by a Plesk Client subscription. On an attempt to delete the record the following error message emerges

At least one CNAME record exists for A record you are going to delete

Cause

CNAME records were propagated from the Plesk Client subscription and therefore can not be deleted from OBAS. At the same time, the culprit A record is absent in Plesk and can be removed from OBAS only, but OBAS does not allow to remove A record if there is at least one CNAME record that points to the A record, no matter if there are other A records in the zone.

Resolution

Please remove CNAME records from Plesk, remove the A record from OBAS and then add the CNAME records back from Plesk. In detail, the resolution steps are:

  1. Go Top > Service Director > Domain Manager > Domains > domain.tld and press Log in to CP

  2. In CP select the subscription in question, proceed to the domain.tld DNS zone and remove all the CNAME records;

  3. Wait several minutes for the Plesk event to be handled by OBAS (or run the Plesk events processing task manually) until CNAME records disappear from OBAS PCC;

  4. Remove the A record in question from under Top > Service Director > Domain Manager > Domains > domain.tld > DNS Zone

  5. Add the CNAME records back in Plesk CP;

  6. Wait several minutes for the Plesk event to be handled by OBAS.

Search Words

At least one CNAME record exists for A record you are going to delete

delete cname

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