Article ID: 128814, created on May 10, 2016, last review on May 10, 2016

  • Applies to:
  • Operations Automation 5.5

Symptoms

Customer has big amount of application users. He is trying to create new application user, but operation takes long time and in 5 minutes error Service unavailable is returned in OA Customer Control Panel. Mentioned negative impact appears if both following conditions are true: 1. APS application requires uniqueness verification of some parameter of new application user (e-mail address for example) 2. End customer has big amount of application users (several thousands)

Cause

This is a result of bug APS-15604: aps 1.2 setting uniqueness checking takes too long, resulting in timeout in CCP UI

Resolution

Please contact your TAM or PTA to trace the status of APS-15604.

As a workaround, it is possible to increase Apache timeout at OA Control Panel / Branding host:

  1. Add directive Timeout <VALUE> in file /usr/local/pem/etc/apache/httpd.conf_pem.override Default timeout is 300 (5 minutes)

  2. Reload Apache configuration:

    /etc/init.d/pemhttpd reload (in case of Legacy Shared Hosting)
    

Search Words

apache timeout

Service Unavailable

Cannot import new APS packages in POA

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