Article ID: 128760, created on Apr 28, 2016, last review on Jun 27, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

MagicSpam for Plesk 12 (Monthly Lease) license key type does not appear in OBAS. KA plug-in reconfiguration does not help.

As a result, MagicSpam licenses can not be provisioned. The following error appears on the Action Log:

[ERROR] [25623] [HSPC::SimpleActionLog::report_problem] Key type "MagicSpam for Plesk (Lease)" not found in client's pricelist

Cause

Such behavior was classified as the software issue PBAS-30294 and was fixed in OBAS 4.5.6.

Resolution

To resolve the issue, please upgrade to 4.5.6 as described in How to upgrade OBAS system to the latest available version.

Hotfix for 4.5.5

If upgrade is not an option for you, below is the hotfix for 4.5.5 version.

Please download a Perl script add_p12magicspam_keys.pl and a patch file named hspc-plugin-lm-ka-keys.patch.

After that, please perform the following actions:

  1. Run the Perl script

    # perl add_p12magicspam_keys.pl
    
  2. To add localized strings to OBAS interface, please run:

    # patch -p 0 -c -i hspc-plugin-lm-ka-keys.patch
    

    If there are no patch program installed on your server, please insert the required localization strings from hspc-plugin-lm-ka-keys.patch to /var/opt/hspc-root/i18n/EN/hspc-plugin-lm-ka-keys.xml manually.

  3. Restart the hspcd service

    # service hspcd restart
    

    Warning: Restart of the hspcd service will cause OBAS downtime for about 10-60 seconds.

Search Words

magicspam

MagicSpam for Plesk 12 (Monthly Lease)

Key type "MagicSpam for Plesk (Lease)" not found in client's pricelist

624ca542e40215e6f1d39170d8e7ec75 caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e

Email subscription for changes to this article
Save as PDF