Article ID: 128641, created on Apr 10, 2016, last review on Apr 10, 2016

  • Applies to:
  • Plesk Automation 11.5


Task Create hosting for the webspace #101 fails for Windows-based subscriptions with error:

Wrong value of php_handler_type/php_version


Not all the required packages were installed during IIS service node deployment.


  1. Login to IIS node as Administrator.

  2. Run cmd.exe as Administrator and install missing packages using following command:

    "%plesk_bin%"\ai.exe --select-product-id panel --select-release-latest --source --install-component php4 --install-component php5 --install-component php53 --install-component php54 --install-component python --install-component perl --install-component tomcat --install-component webdav --install-component awstats --install-component webalizer --install-component ssi

    Note: ai.exe utility should be run with specified arguments only.

  3. Login to Hosting Provider CP and reread list of user-installed packages under Infrastructure > Service Nodes > Windows node name > Refresh.

  4. Restart failed task in Task Manager.

Search Words

system PHP handlers are missing

Service node creation fails: wrong value of php

Wrong value of php_handler_type/php_version

Wrong Value of Php Handler

Install missing PHP handlers

wrong value of php_version

33a70544d00d562bbc5b17762c4ed2b3 caea8340e2d186a540518d08602aa065 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article
Save as PDF