Article ID: 128579, created on Mar 28, 2016, last review on Mar 28, 2016

  • Applies to:
  • Business Automation 6.0

Symptoms

The subscription was created with API. Cancellation order was placed for this subscription, but its provisioning is never completed, it is stuck in Provisioning.

Cause

The subscription was created with incorrect dates (e.g. the last billing date in future).

Deletion Completed event (method OnServiceDelete) fails with an exception Concurrent Billing Order has been processed, please cancel current order.

The fact that order does not fails is a bug with id #PBA-64570 ("Cancellation order may stuck in Provisioning"). Possibility to set wrong dates with API is a bug with id #PBA-64569 ("APIs to create subscriptions do not validate StartDate, LastBillDate parameters").

Resolution

Correct the subscriptions Last Billing Date, which is only possible through the database. Feel free to contact Odin Technical Support for assistance.

Search Words

Cancellation Order stuck

Order in provisioning status

Execution Failed: Concurrent Billing Order has been processed, please cancel current order.

Concurrent Billing Order has been processed, please cancel current order

Concurrent Billing Order has been processed

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