Article ID: 128549, created on Mar 15, 2016, last review on Mar 15, 2016

  • Applies to:
  • Operations Automation 6.0

Symptoms

When opening 'Upgrade server' wizard for a VPS NG subscription in CCP, filling in the required parameters and clicking 'Upgrade', the error message pops up:

This value is out of range

outofrange

Cause

The minimum default value for RAM upsell sliders is defined as 1024, while the server RAM limit is lower. The issue is recognized as CCU-12497 (Can't upgrade VPSNG subscription with "This value is out of range" error message).

Resolution

Find ve.edit.js file with the most recent modification time, e.g.:

[root@mn ~]# locate ui/js/ve.edit.js | xargs ls -alh
-rw-r--r-- 1 pemuser pemgroup 14K Mar 26  2015 /usr/local/pem/APS/packages/6640978c-96e1-4c0b-be1f-1bad3370933f/ui/js/ve.edit.js
-rw-r--r-- 1 pemuser pemgroup 15K Jul 30  2015 /usr/local/pem/APS/packages/aca7629b-d604-4e1b-ab79-1b66638ae8a1/ui/js/ve.edit.js

In the above output the latter file should be used.

Open the file for editing and find the snippet below:

if (!ci.upsellPossible() && !ci.downsellPossible()) {
        dijit.getEnclosingWidget(widget.domNode.parentNode).set("visible", false);
        return;
}

change it to:

if (!ci.upsellPossible() && !ci.downsellPossible()) {
        dijit.getEnclosingWidget(widget.domNode.parentNode).destroy();
        return;
}

Clear web browser cache.

Once the change is done, all future upgrades should not face the problem described above.

Note: in case Cloud Infrastructure APS package gets updated, which happens during OA updates/hotfixes installation, the steps should be repeated for the new package.

Search Words

sda

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0

Email subscription for changes to this article
Save as PDF