Article ID: 128343, created on Feb 15, 2016, last review on Feb 15, 2016

  • Applies to:
  • Plesk Automation 11.5

Symptoms

  1. ppa.autoupdater utility does not work on CentOS 5 with default python-2.4.3-56.el5 package.

  2. On attempt to run script with any argument following error occurs:

    [root@pa115mn ~]# ppa.autoupdater --help
      File "./autoupdater", line 60
        value = 1 if is_enabled else 0
                   ^
    SyntaxError: invalid syntax
    

Cause

The behavior was considered as internal software issue #PPA-3039.

The fix is included in Plesk Automation MU#22.

Resolution

Install latest PA updates according to the article.

For additional information about Plesk Automation Auto-updater please check the article.

Search Words

ppa autoupdater

ppa autoupdater does not work

33a70544d00d562bbc5b17762c4ed2b3 caea8340e2d186a540518d08602aa065 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article
Save as PDF