Article ID: 128159, created on Jan 26, 2016, last review on Jan 26, 2016

  • Applies to:
  • Business Automation 6.0

Symptoms

Account has outdated last daily billing date, on attempt to bill an account manually, an exception occurs:

Account #ID billed with errors

In the logs an exception can be seen:

Daily Billing Process on Account #ID failed with exception: Table Resource Rate doesn't contain row with id Int32(NULL).

Cause

Account billing fails if on one of his subscriptions resources was deleted from the plan resource rates and the subscription was not synced with the changed plan. The issue is considered to be a bug with id #PBA-69771 ("Account Billing fails if resource rate has been deleted from the service plan").

Resolution

Update to BA 6.0.7 as soon as it is available.

To fix an account billing before update installation either sync the subscription with the changed service plan or add the resource back to the service plan. The affected subscription ID, plan ID and resource ID can be found from the logs.

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 3627d36199b8ff577605df76e2fa222b bb7e9177fb03488961a3ea554120f328

Email subscription for changes to this article
Save as PDF