Article ID: 128052, created on Jan 13, 2016, last review on Jan 13, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5


OBAS 4.5.5 is shipped with PHP 5.3. Is there a way to use PHP 5.6 with the OBAS store?


OBAS store was developed and tested with PHP 5.3, therefore there can be issues with later PHP releases.

Nevertheless, there are three options to use PHP 5.6 with the OBAS store.

  1. Deploy OBAS store to a separate Container. does not provide RPM or SRPM packages, only sources. Thus, after the store is deployed to a separate Container, please download PHP sources to that Container and build them with necessary options and modules enabled on configuration stage. That will also make it possible to upgrade the Store with the simple rpm -Uhv hspc-store* command after next OBAS versions are released.

  2. Deploy the OBAS store in Plesk with the required PHP version enabled for a webspace. Please note that it will make the store upgrade rather complicated (but still possible) in case the store is highly customized.

  3. Manually build the necessary PHP packages and install them to the OBAS Management Node. The required packages are php, php-mbstring, php-soap, php-cli and php-common. The list of configuration options can be determined by phpinfo() method call. If you choose to follow this way, you will have to maintain that custom PHP RPMs thence: apply security patches, rebuild packages, upgrade them on the OBAS Management node and so on.

See also

Remote store configuration

PCI Compliance. How to pass the scan test

Search Words

PCI complience

PHP 5.6

upgrade PHP

PCI compliance

624ca542e40215e6f1d39170d8e7ec75 caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e

Email subscription for changes to this article
Save as PDF