Article ID: 127299, created on Oct 31, 2015, last review on Nov 27, 2015

  • Applies to:
  • Operations Automation 6.0
  • Operations Automation 5.5
  • Plesk Automation 11.5

Symptoms

Customer is trying to deactivate the DNS entry:

A    www.customer.com.   1.2.3.4

but it shows the error:

An internal error occurred.
Error ID: 1446116726649 

Operations Automationsversion is below 6.0

The following messages appear in poa.debug.log:

Oct 31 18:14:06 osscore : ERR [UI:91711ae9:24230282:1446315246092 1:14640:acbd3b70 lib]: [txn:3610144 SDK::ChangeDNSRecordStatusObserver::onChangeDNSRecordStatus] ExSystem: module_id:'Common', ex_type_id:'1',Message:'Internal error: void Plesk::SaaS::SaaSManager_impl::updateDNSRecordAPSResourceState(const SDK::TDomain&, const SDK::TDNSRecord&) : [APSC] Resource for record 2726663 is not found..', deprecated_codes = (0, 0), properties = { reason: 'void Plesk::SaaS::SaaSManager_impl::updateDNSRecordAPSResourceState(const SDK::TDomain&, const SDK::TDNSRecord&) : [APSC] Resource for record 2726663 is not found.', }
Oct 31 18:14:06 osscore : ERR [UI:91711ae9:24230282:1446315246092 1:14640:acbd3b70 lib]: [txn:3610144 SDK::ChangeDNSRecordStatusObserver::onChangeDNSRecordStatus] failed to notify observer sc_id 275 [SDK::ChangeDNSRecordStatusObserver] (CORBA::Exception)
Oct 31 18:14:06 osscore : DBG [UI:91711ae9:24230282:1446315246092 1:14640:acbd3b70 lib]: [txn:3610144 SDK::ChangeDNSRecordStatusObserver::onChangeDNSRecordStatus] <=== EXIT (by exception) [0.122681]

Cause

This issue is caused by software-related issue APS-16350 - not all DNS records are propagated to the APS Controller.

Resolution

Upgrade OSA up to 6.0 or higher. During the upgrade system should check and propagate missing records.

To apply the workaround on 5.5 please do the following:

  1. Figure out owner_id for this record:

    plesk=> select owner_id from domains where domain_id = (select domain_id from dns_resource_records where rr_id=2726663);
     owner_id
    ----------
        1020501
    (1 row)
    
  2. Issue the following command as root user on the OA Management node:

    /usr/local/pem/bin/saas_ctl sync_account 1020501 no
    

    where 1020501 is a customer ID domain 'www.customer.com' belongs to.

  3. Make sure the following task passed through afetrwards:

    Propagation of APS 2.0 resources for the account #1020501
    
  4. Activate/deactivate required record

Search Words

An internal Error

[APSC] Resource for record XXXXXX is not found.

An internal error occurred

An internal error occurred. Error ID: 1446116726649

unable to desactivate dns records

dns records created by aps are not removed after cancelling aps subscriptionancelling aps subscription

Internal error: APSC:

Resource for record is not found

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 956c448bddc7e1f3585373687602379f 6f1456866eed87488c0f02b298a741c0 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e 33a70544d00d562bbc5b17762c4ed2b3 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article
Save as PDF