Article ID: 127249, created on Oct 26, 2015, last review on Feb 15, 2016

  • Applies to:
  • Plesk Automation 11.1


Plesk Automation upgrade failed with error:

[ERROR]: Unexpected error: 'PPAUpdater' object has no attribute '_checkDmsScript'
Traceback (most recent call last):
  File "./ppa_upgrade", line 651, in ?
  File "./ppa_upgrade", line 637, in run
  File "./ppa_upgrade", line 573, in _performUpgrade
    self._preUpgrade(dists, distsDirs)
  File "./ppa_upgrade", line 508, in _preUpgrade
AttributeError: 'PPAUpdater' object has no attribute '_checkDmsScript'


The behavior was considered as internal software issue with id #PPA-2875.


The issue was completely fixed in scope of Plesk Automation MU#20.

Search Words

Plesk Automation upgrade failed

PA upgrade failed

Unexpected error: 'PPAUpdater' object has no attribute '_checkDmsScript'

c1ecc6010feff26cb42d1d14a7881dd6 caea8340e2d186a540518d08602aa065 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article
Save as PDF