Article ID: 127041, created on Sep 29, 2015, last review on Sep 29, 2015

  • Applies to:
  • Business Automation 6.0


BA upgrade could fail due to inability to upgrade the libcurl721 rpm to version >= 7.37

The upgrade fails with the following error in a log:

Error: Package: curl721-7.21.7-5.el6.x86_64 (@pa-central-repo)
           Requires: libcurl721 = 7.21.7-5.el6
           Removing: libcurl721-7.21.7-5.el6.x86_64 (@pa-central-repo)
               libcurl721 = 7.21.7-5.el6
           Updated By: libcurl721-7.37.0-13.el6.x86_64 (pa-central-repo)
               libcurl721 = 7.37.0-13.el6


Earlier, Odin provided two rpms: libcurl721 and curl721 of version 7.21. The curl721 package stricly requires libcurl721 of the same version.

Later, curl721 was dropped from the "pa-central-repo" yum repository, and version of libcurl721 was bumped.

As a result, an attempt to upgrade BA fails on inability to upgrade the libcurl721 package.


Remove the curl721 rpm from the affected host:

rpm -e curl721

198398b282069eaf2d94a6af87dcb3ff caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 3627d36199b8ff577605df76e2fa222b bb7e9177fb03488961a3ea554120f328

Email subscription for changes to this article
Save as PDF