Article ID: 126998, created on Sep 25, 2015, last review on Sep 25, 2015

  • Applies to:
  • Operations Automation 5.5

Symptoms

An APS-related task fails with an error like below:

Task name       Provisioning "context" for APS application BlackBerry 10
Last execution output   Internal error: SDK::Platform::blob Plesk::SaaS::SaaSManagerTasks_impl::taskExecuteWorkflow(const SDK::Platform::Properties&) : [APSC] system exception, ID 'IDL:omg.org/CORBA/TRANSACTION_ROLLEDBACK:1.0'  Unknown vendor minor code id (0), minor code = 0, completed = NO

Cause

The issue is probably caused by APS-15464, which was fixed in OA 5.5.5.

The cause is that during task execution DB connection times out while APSC transaction is still running, the connection is killed and the corresponding transaction is rolled back.

Resolution

Please uodate to version higher than or 5.5.5.

To workaround update the following parameter in /usr/local/pem/etc/Kernel.conf file on POA Management node to higher values:

db_service.connection_timeout
db_service.transactional_connection_timeout

Recommended values for both are 1200, but it could vary depending on the task.

After the change, restart pem service on POA Management Node and re-run the task.

Search Words

TRANSACTION_ROLLEDBACK

Unknown vendor minor code id

Internal error: SDK::Platform::blob Plesk::SaaS::SaaSManagerTasks_impl::taskExecuteWorkflow(const SDK::Platform::Properties&) : [APSC] system exception, ID 'IDL:omg.org/CORBA/TRANSACTION_ROLLEDBACK:1.0' Unknown vendor minor code id (0), minor code = 0, completed = NO

failed APS tasks

5356b422f65bdad1c3e9edca5d74a1ae caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 5b048d9bddf8048a00aba7e0bdadef37 2554725ed606193dd9bbce21365bed4e

Email subscription for changes to this article
Save as PDF