Article ID: 126512, created on Aug 10, 2015, last review on Aug 10, 2015

  • Applies to:
  • H-Sphere 3.6.3

Symptoms

One of mail servers doesn't support smtp AUTH LOGIN even though /var/qmail/control/options has "smtpauth=1" enabled.

When trying to connect to localhost it works fine:

[root@mail ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.domain.tld (127.0.0.1).
Escape character is '^]'.
220 mail.domain.tld ESMTP
ehlo abc
250-mail.domain.tld
250-PIPELINING
250-8BITMIME
250-SIZE 52428800
250-AUTH LOGIN PLAIN CRAM-MD5
250 STARTTLS
AUTH LOGIN
334 VXNlcm5hbWU6

but when try to access by hostname the issue occur.

[root@mail ~]# telnet mail.domain.tld 25
Trying 10.10.10.10...
Connected to mail.domain.tld (10.10.10.10).
Escape character is '^]'.
220 mail.domain.tld ESMTP
ehlo abc
250-mail.domain.tld
250-PIPELINING
250-8BITMIME
250-SIZE 52428800
250 STARTTLS
AUTH LOGIN
502 unimplemented (#5.5.1)

Cause

Custom Mail rule.

Resolution

The issue is caused by the following line:

[root@mail]# cat /hsphere/local/var/vpopmail/etc/tcp.smtp
...
10.10.10.:allow,RELAYCLIENT="",AUTHSENDER="0",HELODNSCHECK="0",MFDNSCHECK="0",NULLSENDERMULTRCPTS="1",QUITASAP="0",RCPTDNSCHECK="0",SMDCHECK="0",SMTPAUTH="0",STRIPSINGLEQUOTES="0",USERCHK="0"

To change these settings go to CP->E.Manager->Servers->Mail Servers and change rule which match IP/Subnet you are experiencing the issue from. Set SMTPAUTH to 1.

Search Words

AUTH LOGIN 502 unimplemented (#5.5.1)

6b908665c0d1eca5bdd0141a32fd712a 6311ae17c1ee52b36e68aaf4ad066387 f213b9fa8759d57bee5d547445806fe7 2e39a5e5b1423cc126cf735bac076008

Email subscription for changes to this article
Save as PDF