Article ID: 126339, created on Jul 27, 2015, last review on Apr 29, 2016

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

DNS records of all domains of a certain Plesk node do not propagate to OBAS unless a Plesk domain is manually synchronized under Top > Service Director > Plesk Manager > Domains > domain.tld > Synchronize DNS or the domain DNS zone is restarted in OBAS under Top > Service Director > Domain Manager > Domains > domain.tld > DNS Zone tab > Disable zone, then Enable zone.

Cause

After something is changed on a Plesk node it produces an event stored in Plesk database under some ID. OBAS checks and processes those events periodically with the Plesk events processing task for all Plesk nodes and with Plesk Node #N events process non-periodic tasks for a single Plesk node. Last processed event ID for each Plesk node is stored in OBAS database.

The Plesk node in question was migrated/upgraded/restored after a back up on a different server thus restarting Plesk events counter and breaking events numbers synchronization between Plesk and OBAS.

Or, alternatively, DNS records were updated right in Plesk database by the script /usr/local/psa/bin/repair that does not write events in Plesk database.

Resolution

Solution implies database editing, therefore it is recommended to contact Odin Technical Support for assistance.

Search Words

Plesk events processing

Domain DNS zone is not synchronized with Plesk

Disable zone

DNS zone management

DNS records are not propagated from Plesk

/usr/local/psa/bin/repair

plesk not synchronizing

Synchronize DNS

no dns propagation

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