Article ID: 126122, created on Jul 9, 2015, last review on Jul 9, 2015

  • Applies to:
  • Plesk Automation

Symptoms

Error occurs during the infrastructure check of migration:

│ └ error: Unable to copy the sample file from the source server 'source' (<IP>) to PPA service node '<node_name>' (#4, <IP>) using 'rsync'.
│
│   Please check that:
│   1) There are no firewall rules blocking SSH connections from the PPA node to the source server.
│   TCP port 22 on the source server is open for incoming connections, TCP port 22 on the PPA node is open for outgoing connections.
│   2) The SSH service is running on the source server.
│   3) The source server allows using the key-based SSH authentication for the PPA node.
│
│   The following command has failed:
│   Command the migrator tried to execute on PPA service node '<node_name>' (#4, <IP>) was: /usr/bin/rsync -e 'ssh -i /root/.ssh/id_dsa.dsfgfdg -o StrictHostKeyChecking=no' --archive root@<IP>:/tmp/check-rsync-testfile-mail /tmp/check-rsync-testfile-mail
│   exit code: 1
│   stdout:
│   stderr: execve: No such file or directory

Cause

Rsync is not installed on the mentioned service node:

[root@ppa_sn ~]# rpm -qa | grep rsync
[root@ppa_sn ~]#

Resolution

  1. Install rsync package:

    [root@ppa_sn ~]# yum install rsync
    
  2. Re-run migration.

Search Words

check

error

infrastructure

rsync

Migration

e0aff7830fa22f92062ee4db78133079 caea8340e2d186a540518d08602aa065

Email subscription for changes to this article
Save as PDF