Article ID: 125789, created on Jun 9, 2015, last review on Jun 9, 2015

  • Applies to:
  • Odin Business Automation Standard 4.5

Symptoms

OS update on an OBAS server done in accordance with How to update the OS (minor) of a OBAS server fails with one of the following errors:

1.

Error: Package: perl-Test-Simple-0.92-136.el6_6.1.x86_64 (updates)
           Requires: perl = 4:5.10.1-136.el6_6.1
           Installed: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
               perl = 4:5.10.1-131.el6.parallels
Error: Package: perl-Test-Harness-3.17-136.el6_6.1.x86_64 (updates)
           Requires: perl = 4:5.10.1-136.el6_6.1
           Installed: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
               perl = 4:5.10.1-131.el6.parallels
Error: Package: perl-ExtUtils-MakeMaker-6.55-136.el6_6.1.x86_64 (updates)
           Requires: perl = 4:5.10.1-136.el6_6.1
           Installed: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
               perl = 4:5.10.1-131.el6.parallels
Error: Package: 4:perl-devel-5.10.1-136.el6_6.1.x86_64 (updates)
           Requires: perl = 4:5.10.1-136.el6_6.1
           Installed: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
               perl = 4:5.10.1-131.el6.parallels
Error: Package: 1:perl-ExtUtils-ParseXS-2.2003.0-136.el6_6.1.x86_64 (updates)
           Requires: perl = 4:5.10.1-136.el6_6.1
           Installed: 4:perl-5.10.1-131.el6.parallels.x86_64 (installed)
               perl = 4:5.10.1-131.el6.parallels
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles –nodigest

2.

Error: Package: perl-Mouse-0.58-2.1.el6.x86_64 (epel)
       Requires: perl(Test::Builder)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles –nodigest

Cause

  1. All of those packages were installed manually. They are not required for OBAS functionality.
  2. The package was installed from a third-party repository (EPEL in our example).

Resolution

  1. Add the packages to the list of excluded ones in the yum update command by using -x key.
  2. Remove the third-party repository from yum repositories list:

    [root@server ~]# ll /etc/yum.repos.d/
    total 28
    -rw-r--r-- 1 root root 1926 Nov 30  2013 CentOS-Base.repo
    -rw-r--r-- 1 root root  638 Nov 30  2013 CentOS-Debuginfo.repo
    -rw-r--r-- 1 root root  630 Nov 30  2013 CentOS-Media.repo
    -rw-r--r-- 1 root root 4528 Nov 30  2013 CentOS-Vault.repo
    -rw-r--r-- 1 root root  957 Nov  4  2012 epel.repo                 <---- EPEL repository
    -rw-r--r-- 1 root root 1056 Nov  4  2012 epel-testing.repo         <---- EPEL repository   
    
    [root@server ~]# rm -f /etc/yum.repos.d/epel*
    [root@server ~]# rpm -qa |grep epel
    epel-release-6-8.noarch
    [root@server ~]# rpm -e epel-release-6-8.noarch
    

Search Words

Error package

You could try using --skip-broken to work around the problem

OS update

CentOS update

You could try running: rpm -Va --nofiles –nodigest

Perl update

624ca542e40215e6f1d39170d8e7ec75 caea8340e2d186a540518d08602aa065 400e18f6ede9f8be5575a475d2d6b0a6 70a5401e8b9354cd1d64d0346f2c4a3e

Email subscription for changes to this article
Save as PDF